| |
| | |

Printer Forum   

 Forgot password?
 register
Search
View: 1599|Reply: 3

my epson stylusNX110 won't recognize my replacement cartridges,what ca

[Copy link]

Post time: 2012-12-25 09:13:22 |Show all posts
my epson stylusNX110 won't recognize my replacement cartridges, what can i do?
--Epson Stylus Multifunction Printer/ Copier/ Scanner InkJet

Post time: 2013-1-3 13:18:18 |Show all posts
try to use the SSC epson reseter...
this should fix your Printer!
Good Luck!
Here´s the link: www.ssclg.com/epsone.shtml

Post time: 2012-12-31 07:21:57 |Show all posts
Generic carts are sometimes not recognized. Epson's chips are the cause. I solved this problem for a small investment. I purchased a CISS system for about $75.00 [ink included], that's the cost of OEM carts that do not last very long. The CX9400Fax is an Ink Hog, which is why the printer is so cheap. If you want a CISS go to http://www.inkproducts.com/ink-store/  They are great if you need help and will call you back in less than an hour. Get the Waste Ink Kit when ordering the CISS.

Post time: 2012-12-28 04:50:58 |Show all posts
Just had this happen to me.  Turned it off, turned it back on... nothing.  In/out with the cartridge several times and when I blew on the contacts of the printer (where the little microchio on the cartridge touches) it finally worked.  Did the blowing on the contacts help?  Maybe, but more likely is that the it was just repeatedly trying to d oit before the machine figured it out.
You have to log in before you can reply Login | register

Advertise on OASQ.COM| Contact us| Archive| OASQ

2021-11-27 18:17 GMT-8

Powered by Discuz! 7.2

Release 20121101, © 2001-2021 OASQ.

To Top