| |
| | |

Printer Forum   

 Forgot password?
 register
Search
View: 716|Reply: 1

Samsung CLP-300 Image Ghosting

[Copy link]

Post time: 2015-6-26 14:45:45 |Show all posts
I am getting echos/ghosting on all output. I have considered a problem with the Image Transfer Belt but most posts indicate these last almost indefinitely. If I clean the belt, the ghosting goes away for a couple of pages but comes right back. It appears that a faint amount of toner is remaining on the belt to be transferred on the next rotation of the belt. Whatever should be cleaning the belt is not working. The belt itself is in good condition; no damage, and it cleans of manually quite easily.
I have not tried replacing the belt but really don't want the expense of a new ITB if that is not the problem. Any other troubleshooting tips would be appreciated.

Post time: 2015-6-26 16:03:57 |Show all posts
you answered your own question. if you clean the belt, the print is better. You need a new transfer belt. These belts clean themselves. Check ebay for a NEW transfer belt. The colour toner is abrasive, so therefore wear the belt, prematurely. If you are printing Black mainly, the Belt will last longer.
Its a nice little machine for home use. And cheaper than Inkjets, where you use a liquid as opposed to a powder.
You have to log in before you can reply Login | register

Advertise on OASQ.COM| Contact us| Archive| OASQ

2019-8-24 13:26 GMT-8

Powered by Discuz! 7.2

Release 20121101, © 2001-2019 OASQ.

To Top