| |
| | |

Printer Forum   

 Forgot password?
 register
Search
View: 1307|Reply: 6

Olympia Startype

[Copy link]

Post time: 2013-5-31 16:17:17 |Show all posts
Would anyone have a working printer or complete machine?
Thank you,
Dave

Post time: 2013-6-1 00:55:08 |Show all posts
Dave, pull the power supply and check AC voltage across the large C1 capacitor.  500 VAC or more is a good reading.  If it is around 480, it can cause extra cycles of the ribbon motor, especially when you use the correction key.
I started in this business in 1962, and Olympia since 66 or 67. I have found many problems can cause the same symptoms, but I alway check the power supply first.

Post time: 2013-5-31 23:35:56 |Show all posts
Ah!  The Hall-effect PCB; I skipped over that one.
Not a difficult fix if you can find one of the sensor PCB's anymore.
We are talking about the Olympia AEG version (ES-9x series), right?
p/n 662002030200 - PCB w/Hall Generator

Post time: 2013-5-31 22:06:58 |Show all posts
Gear is fine. It's the home sensor on the right side.

Post time: 2013-5-31 21:01:26 |Show all posts
Whoops; forgot about carrier fuse popping!

Post time: 2013-5-31 19:35:23 |Show all posts
First bet?  Shattered gear.
Second:  C1

Post time: 2013-5-31 17:37:50 |Show all posts
Dave, what is your actual problem with the printer?
You have to log in before you can reply Login | register

Advertise on OASQ.COM| Contact us| Archive| OASQ

2022-1-28 20:08 GMT-8

Powered by Discuz! 7.2

Release 20121101, © 2001-2022 OASQ.

To Top